Empezando con la guayaba

Configuración

La dependencia de Guava se puede agregar en su proyecto Java utilizando cualquier sistema de compilación.

Maven:

<dependency>
  <groupId>com.google.guava</groupId>
  <artifactId>guava</artifactId>
  <version>19.0</version>
</dependency>

** Graduado: **

dependencies {
  compile 'com.google.guava:guava:19.0'
}

Hiedra

<dependency org="com.google.guava" name="guava" rev="19.0" />

Constructor

compile.with 'com.google.guava:guava:jar:19.0'

Dependencia manual

También puede simplemente descargar archivos JAR manualmente desde la página de lanzamiento de Guava para las clases, fuentes y javadocs.

Tenga en cuenta que se requiere JDK 1.6 o posterior para Guava 12.0 a 20.0. Consulte la lista de versiones para obtener más información. Los usuarios de Guava que apuntan a Java 5 deben usar el backport Guava JDK5. Esto incluye a los usuarios que apuntan a Android Froyo y versiones anteriores.